Couldn’t load module /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /interlink.so

Couldn’t load module /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /interlink.so

If installed Wireshark1.8 over an older version on Mac OS, you may have seen these errors messages:

Wireshark 1.8 error

Wireshark 1.8 error

Couldn't load module /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /interlink.so: dlopen( /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /interlink.so, 10): Symbol not found: _dissector_get_port_handle
Referenced from: /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /interlink.so
Expected in: flat namespace
in /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /interlink.so

Wireshark 1.8 error

Wireshark 1.8 error

Couldn't load module /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /sercosiii.so: dlopen( /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /sercosiii.so, 10): Symbol not found: _dissector_add
Referenced from: /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /sercosiii.so
Expected in: flat namespace
in /Applications /Wireshark.app /Contents /Resources /lib /wireshark /plugins /sercosiii.so

This is because an old library has not been removed by the installation program.

To correct that, just remove every file:
$ rm -rf /Applications/Wireshark.app

Then run the 1.8 installation program again.

Wireshark

Wireshark

Et voilà! This time it was really successful.

Source: Wireshark Bug Database – Bug 7401

Tags

Like this Article? Share it!

About the Author

Author Gravatar
Benjamin Bellamy

Paris, Beirut, NYC & Agen // e-commerce, social media, open-source & geek // follow me on twitter: @benjaminbellamy.

Related Posts

Comments are closed.